Back to overview
Degraded

Advanced Cloud Storage (us-west-1) is down

Oct 20 at 08:47am CDT
Affected services
Advanced Cloud Storage (us-west-1)

Resolved
Oct 20 at 08:47am CDT

Advanced Cloud Storage (us-west-1) recovered.

Created
Oct 20 at 08:47am CDT

Advanced Cloud Storage (us-west-1) is degraded.